Content management and e-commerce platforms move their PHP requirements on their own schedules, and the next few months bring several deadlines at once: PHP 8.2's security support ends on 31 December 2026, Drupal 10 ends in December, and Joomla 5 has already left regular bug-fix support. This guide collects the official requirements for Drupal, Joomla and Magento (Adobe Commerce) as published on each project's site at the end of October 2026, so you can plan PHP and platform upgrades together.
PHP's calendar first
According to php.net, PHP 8.2 receives security fixes until 31 December 2026, PHP 8.3 until 31 December 2027, PHP 8.4 until 31 December 2028 and PHP 8.5 until 31 December 2029. PHP 8.1 reached end of life on 31 December 2025. A platform version that only supports PHP 8.2 or older is therefore on borrowed time, whatever the platform's own dates say.
Drupal
Drupal's PHP requirements page lists the supported PHP versions per minor release:
| Drupal | Supported PHP |
|---|---|
| 10.4, 10.5, 10.6 | 8.1, 8.2, 8.3, 8.4 |
| 11.1, 11.2 | 8.3, 8.4 |
| 11.3, 11.4 | 8.3, 8.4, 8.5 |
| 12.0 | 8.5 only |
The release schedule adds the dates. Drupal 11.4 is the current feature branch (11.4.11 was released on 21 October 2026). Drupal 12.0.0 and 11.5.0 are scheduled for the week of 7 December 2026, and that same week security support ends for 11.3.x and 10.6.x. Drupal 10 reaches end of life on 9 December 2026; 10.6 is its last minor release. Drupal 7 has been end of life since 5 January 2025.
Two details matter for hosting. First, Drupal 12 will need PHP 8.5, so a Drupal 12 upgrade starts with a PHP 8.5 environment. Second, from Drupal 12.0 PHP should be compiled with argon2 support for password hashing; Drupal's page says this should already be the case on most or all PHP 8.5 installations. Drupal also notes that its upstream dependencies may drop old PHP versions before a Drupal major version ends, and the site's status report warns when the PHP installation is getting too old.
Joomla
Joomla publishes recommended and minimum versions per major series in its technical requirements, and support dates on its roadmap:
| Joomla | PHP recommended | PHP minimum | Bug fixes until | Security fixes until |
|---|---|---|---|---|
| 6.x (current 6.2.0) | 8.4 | 8.3.0 | 17 October 2028 | 16 October 2029 |
| 5.x (current 5.4.10) | 8.3 | 8.1.0 | 13 October 2026 (ended) | 12 October 2027 |
Joomla 5.4 is the last minor release of the 5 series and back-ports API changes from 6.x to ease the move. Joomla 6 requires at least PHP 8.3, so a Joomla 5 site on PHP 8.1 or 8.2 needs a PHP upgrade before or together with the Joomla 6 upgrade. Joomla 6 lists these PHP extensions as required: json, simplexml, dom, zlib, gd, and mysqlnd or pdo_mysql or pdo_pgsql; mbstring is recommended, along with a PHP memory limit of at least 256 MB.
Magento Open Source and Adobe Commerce
Adobe's system requirements page (last updated 13 October 2026) lists the PHP versions tested with each 2.4.x line, and states that Adobe supports only the listed combinations:
| Release line | Latest patch listed | PHP |
|---|---|---|
| 2.4.9 | 2.4.9 | 8.5 |
| 2.4.8 | 2.4.8-p5 | 8.4, 8.3 |
| 2.4.7 | 2.4.7-p10 | 8.3, 8.2 |
| 2.4.6 | 2.4.6-p15 | 8.2, 8.1 |
Adobe's lifecycle policy for Adobe Commerce gives 2.4.9 (released 12 May 2026) regular support until 31 May 2029, 2.4.8 until 31 May 2028 and 2.4.7 until 31 May 2027. Standard support for 2.4.6 ended on 11 August 2026, with extended support to 31 August 2027. These dates are Adobe's policy for Adobe Commerce; Magento Open Source shares the same 2.4.x release numbers and the same requirements page, which also lists the PHP extensions Magento Open Source needs. The table makes the planning problem visible: 2.4.6 runs on PHP 8.1 or 8.2 and 2.4.7 on PHP 8.2 or 8.3, while PHP 8.1 is already end of life and 8.2 loses security support in December. Moving to 2.4.8 or 2.4.9 also means moving PHP, MariaDB or MySQL, OpenSearch and Composer to the versions Adobe lists for that line.
Check your own site
The tables tell you what the platform supports; your installed modules and extensions decide what is possible. For Composer-managed projects (Drupal and Magento), these commands help, run in the project directory with the same PHP version the site uses:
php -v
composer show drupal/core # installed Drupal core version
composer prohibits php 8.4 # which packages block PHP 8.4
composer check-platform-reqs # does this PHP satisfy composer.lock?composer prohibits php 8.4 lists the packages whose constraints exclude that PHP version, which is a quick way to find the contributed modules or extensions that must be updated first. For Joomla, check the requirements of each installed extension with its developer before the PHP change.
A sensible order
- Take a full backup of files and database, and confirm it restores.
- Update the platform to the latest patch release of your current line, still on your current PHP.
- On a staging copy, move PHP to a version supported by both your current and your target platform release (for example PHP 8.3 for Joomla 5 to 6, or PHP 8.3 or 8.4 for Drupal 10.6 to 11.4).
- Update modules and extensions, then run the platform upgrade on staging and test the full customer journey.
- Repeat on production in a maintenance window with the old PHP still installed for rollback.
Pitfalls
- Upgrading PHP on production first and discovering an extension that does not support it.
- Missing PHP extensions on the new version: on Debian and Ubuntu each PHP version has its own extension packages.
- Forgetting the database and search services, which Adobe ties to specific Commerce lines.
- Waiting for the last week: Drupal 10's end of life and PHP 8.2's end of security support fall in the same month.
What you should do
- Inventory each site's platform version, PHP version and key extensions.
- Drupal 10 sites: plan the move to Drupal 11.4 (PHP 8.3 or newer) before 9 December 2026, and plan Drupal 12 together with PHP 8.5.
- Joomla 5 sites: they now receive security fixes only, until 12 October 2027; plan Joomla 6 on PHP 8.3 or newer.
- Magento and Adobe Commerce stores on 2.4.6 or 2.4.7: plan the move to 2.4.8 or 2.4.9 along with the PHP and service versions Adobe lists.
- Move every site off PHP 8.2 and older before 31 December 2026.
Sources
- drupal.org/docs/getting-started/system-requirements/php-requirements
- drupal.org/about/core/policies/core-release-cycles/schedule
- drupal.org/project/drupal
- manual.joomla.org/docs/get-started/technical-requirements
- manual.joomla.org/docs/5.4/get-started/technical-requirements
- developer.joomla.org/roadmap.html
- downloads.joomla.org
- experienceleague.adobe.com/en/docs/commerce-operations/installation-guide/system-requir...
- experienceleague.adobe.com/en/docs/commerce-operations/release/planning/lifecycle-policy
- experienceleague.adobe.com/en/docs/commerce-operations/release/versions
- experienceleague.adobe.com/en/docs/commerce-operations/release/notes/magento-open-sourc...
- getcomposer.org/doc/03-cli.md#prohibits-why-not
- getcomposer.org/doc/03-cli.md#check-platform-reqs
- php.net/supported-versions.php
- php.net/eol.php
Comments
0 total · 0 threads