Security advisory Debian

nginx DSA-6496-1 and DLA-4784-1 (September 2026): map/regex buffer overflow fixed in Debian 13 and 12

DSA-6496-1 and DLA-4784-1 fix a major-rated nginx buffer overflow and two medium bugs in Debian 13 and 12. Includes earlier 2026 nginx updates.

Published
Reading time
5 min read

Security advisory Vulnerability

Severity: High Status: Patched
Status
Fixed versions are available for Debian 13 (trixie) and Debian 12 (bookworm).
Affected
  • nginx in Debian 13 (trixie) before 1.26.3-3+deb13u8
  • nginx in Debian 13 (trixie) before 1.26.3-3+deb13u9
  • nginx in Debian 12 (bookworm) before 1.22.1-9+deb12u10
Published
Updated

What you should do

  • Upgrade to the newest nginx package for your release: 1.26.3-3+deb13u10 on trixie, 1.22.1-9+deb12u10 on bookworm.
  • Restart nginx after the update and confirm it is running.
  • Give priority to servers with complex map/regex logic, SSI, or slice-based range caching.
  • If you build third-party modules on trixie, rebuild them against the current nginx-dev.
Timeline
  1. Debian published DSA-6131-1 for nginx.
  2. Debian published DSA-6278-1 for nginx.
  3. Debian published DSA-6326-1 for nginx.
  4. Debian published DSA-6374-1 for nginx.
  5. The Debian LTS team published DLA-4667-1 for nginx.
  6. Debian published DSA-6496-1 for nginx.
  7. Debian published DSA-6496-2 for nginx.
  8. The Debian LTS team published DLA-4784-1 for nginx.
  9. Skyline published this summary.

In September 2026 Debian released an nginx update for both supported releases: DSA-6496-1 for Debian 13 (trixie) on 12 September and DLA-4784-1 for Debian 12 (bookworm) on 17 September. It fixes three vulnerabilities, one of which nginx rates "major", its highest category. A follow-up, DSA-6496-2, fixed a packaging regression on trixie four days later. This page also summarises the earlier nginx advisories of 2026.

At a glance

ItemDetails
Source packagenginx
Debian 13 (trixie)1.26.3-3+deb13u8 (DSA-6496-1), regression fix 1.26.3-3+deb13u9 (DSA-6496-2)
Debian 12 (bookworm)1.22.1-9+deb12u10 (DLA-4784-1)
CVEsCVE-2026-42533 (major), CVE-2026-56434 (medium), CVE-2026-60005 (medium)
SeverityHigh (nginx rates CVE-2026-42533 major)
Newer updateTrixie has since received DSA-6575-1 (1.26.3-3+deb13u10, 21 Oct 2026)

What the vulnerabilities are

Debian says these issues "may result in denial of service, memory disclosure or potentially the execution of arbitrary code".

  • CVE-2026-42533, heap buffer overflow in the script engine (major). It can be triggered when a map directive performs regular-expression matching and a string expression references captures modified by the map, or when non-cacheable variables change between the two passes nginx uses to build a string. F5, the CNA, scores it CVSS 3.1 8.1 with high attack complexity, and CISA's assessment on cve.org records a public proof of concept. It is not in the CISA Known Exploited Vulnerabilities catalog as of 30 October 2026.
  • CVE-2026-56434, use-after-free with server-side includes (medium). Seen in configurations that combine SSI with proxy_pass and proxy_buffering off, when an upstream response causes a subrequest to be finalised twice.
  • CVE-2026-60005, memory disclosure (medium). A regex match failure could leave stale capture information, so a later unnamed capture could read uninitialised memory. nginx lists it under the slice module.

The regression update, DSA-6496-2, affected only the nginx-dev package: the backported fix declared two private headers that nginx-dev does not ship, so third-party modules could no longer be built against it. If you compile your own nginx modules on trixie, make sure you have at least 1.26.3-3+deb13u9.

Earlier nginx advisories in 2026

AdvisoryDateCVEs (nginx rating)Debian 13Debian 12
DSA-6131-112 FebCVE-2026-1642 (medium): injection when proxying to an upstream TLS server1.26.3-3+deb13u21.22.1-9+deb12u4
DSA-6278-116 MayCVE-2026-42945 (medium), CVE-2026-40701 (medium), CVE-2026-42934 (low)1.26.3-3+deb13u51.22.1-9+deb12u7
DSA-6326-17 JunCVE-2026-9256 (medium), CVE-2026-42946 (medium)1.26.3-3+deb13u61.22.1-9+deb12u8
DSA-6374-1 / DLA-4667-130 Jun / 3 JulCVE-2026-42055 (medium), CVE-2026-48142 (low)1.26.3-3+deb13u71.22.1-9+deb12u9

Each nginx package includes all earlier fixes, so installing the newest version for your release covers every row.

Are you affected?

dpkg -l 'nginx*' 'libnginx-mod-*'
apt policy nginx nginx-common

On Debian 12 you need at least 1.22.1-9+deb12u10. On Debian 13 you need at least 1.26.3-3+deb13u9 for this advisory, and 1.26.3-3+deb13u10 to include the October fixes. To see whether you use the features involved, search the full configuration:

sudo nginx -T 2>/dev/null | grep -nE '^\s*(map|ssi|proxy_buffering|slice)\b'

A match is not proof of exposure, and no match is not a reason to skip the update; it only helps you prioritise. Debian 11 (bullseye) is past the end of LTS and should be upgraded.

How to update

sudo apt update
sudo apt upgrade

Bookworm receives LTS updates from the usual bookworm-security repository. Ubuntu builds differ; see Ubuntu Security Notices.

Restart or reboot?

No reboot is needed. Check the configuration and restart nginx so all worker processes run the fixed code:

sudo nginx -t
sudo systemctl restart nginx

Sources

SKYLINE Engineering

@skyline

The engineering team at SKYLINE Industrial Solutions. We publish field-tested guides drawn from real KSA and GCC deployments.

See author profile
SKYLINE engineering services

Need this implemented for you?

Reading is free — building it right takes a team. SKYLINE engineers ship Debian for Aramco vendors, banks, hospitals and government agencies across Saudi Arabia. Talk to us before you start.

Aramco Approved Contractor ISO 9001 · ISO 27001 SAMA CSF aligned NCA ECC ready 247+ KSA clients

Comments

0 total · 0 threads
Be the first to leave a comment.